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Introduction

In this tutorial, I have compiled technical tips from two reference books: Digital  
Exposure Handbook by Ross Hoddinott and Architectural Photography by Adrian 
Schulz.

This example Workflow is biased towards applications for architectural and interior 
photography. It's mostly reusable for general photograph enhancement, but it covers 
subjects such as perspective corrections, but not skin tone optimisation for example.

Before you start: Calibrate your Monitor using Adobe Gamma

- Utility installed alongside Photoshop on Windows PC.

- My Computer > Control Panel > Adobe Gamma and follow the on-screen 
instructions.

I) Why work in RAW format rather than jpeg?

− RAW encodes all pixels whereas jpeg compresses data by comparing pixels to 
their neighbours. This may create artefacts when said pixels are modified in 
post-processing.

− Jpeg has a color depth of 8 bits per color channel, therefore 256 levels can be 
encoded. RAW uses 12 or 14 bits per color channel, allowing 4096 or 16 384 
shades respectively.

II) RAW Conversion (using Adobe Camera Raw ACR Converter)

1) Adjust the White Balance using one of these 2 methods:
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- Manual WB using the Temperature and Tint sliders: adjust the colour temperature of 
the image using the Temperature slider, then do small adjustments with the Tint 
slider.

- Semi-automated WB with the WB tool: more precise, on the condition that you can 
identify a patch of the image corresponding to neutral grey in the real world. Select it 
with the eyedropper tool.

2) Histogram
- activate Shadow and Highlight clipping warning. Clipped highlights are marked in 
red, clipped shadows in blue.

3) Basic Panel
- Slide Contrast a little to the left and adjust shadows and highlights individually 
using the Recovery and Fill Light sliders. The contrast is now reduced to avoid 
clipping in subsequent more elaborate steps of the post-processing.

- The Clarity setting increases the local contrast of the image but tends to create halos 
around contrast-rich edges so must be used with caution.

- Vibrance and Saturation should be left in neutral position as these settings are better 
adjusted in later steps.

4) Tone Curve Panel
- Adjusting the tone curve determines the brightness in the image.

- Point method allows to manipulate the curve directly.

- Parametric method adjusts the curve with 4 sliders controlling Highlights, Lights, 
Darks, Shadows.

- Manipulating the curve into a 'S' shape adds contrast to the midtones. Manipulating 
the curve into an inverted 'S' shape reduces contrast in the midtones.

5) Details Panel
- Perform only minor sharpening if any. Sharpening should be one of the very last 
steps of the workflow otherwise it may create artefacts.

- Set Amount between 10 and 20.

- Set Radius no higher than 1.

- Set Detail between 5 and 15.

- Leave Masking at a low setting.

- A slight reduction of Colour Noise should be done using the slider. More elaborate 
noise reduction will be done later in photoshop because photoshop can identify the 
type of noise, and therefore does more efficient noise reduction.



6) HSL/Greyscale Panel
- HSL = Hue, Saturation, Luminance

- Hue: small corrections within selected colours (for example correct the sky for the 
redness typical of digital images).

- Saturation: at this early stage, only use it for small intensity corrections needed as a 
side effect of earlier manipulations. For example, while bright areas manually 
darkened and dark areas manually lightened seem to have more intense colours, the 
darkening of already dark areas and the brightening of already bright areas result in 
loss of colour intensity that may require correction.

- Luminance allow to adjust the brightness of selected colours.

- Checking the box Convert to grayscale converts the image to B&W. Grey values 
can be set for each colour individually using the sliders, in order to create unusual 
B&W images.

7) Split Toning Panel
- Allows individual adjustments of colours for bright and dark areas. Useful when 
areas in the shadows show up tinted while other areas show the correct colour.

- Also allows tinting of images previously converted to greyscale (for example, Sepia 
tinting).

- Those adjustments however are rarely done at this stage.

8) Lens Correction Panel
- Correct optical aberrations caused by the lens such as colour-fringes, chromatic 
aberrations and Lens vignetting (fall-off of light toward the corners of an image).

9) Additional Options
- Spot Removal tool: useful to remove specks caused by dust on the sensor.

- Straighten tool: draw a line through the image to use as a direction for straightening. 

- But Crop and Straighten tools should not be used at this stage if you plan on 
correcting distortions later in the workflow.

10) Convert the image to RAW
- Select the Colour Space: sRGB is best for most Internet and PhotoLab uses, while 
the larger Adobe RGB colour space is best for advanced devices able to show enlarged 
colour range (some high end monitors and ink jet printers).

-  Select a Depth of 16 Bits/Channel, unless the computer is very low in computing 
power in which case select 8 Bits/Channel.
- Leave the Size setting alone, unless you wish to interpolate the image to a larger 
format. In that case, do it at this stage while the software is still working with 
unadulterated raw data to ensure maximum quality.



- Resolution may be left alone, it does not affect the number of pixels in the image.

- Set the Sharpen for setting to None.

- Uncheck the box Open in Photoshop as Smart Object.

III) Image Correction in Photoshop

This is to fine-tune or do more elaborate corrections that what we did in the RAW 
converter.

1) Simultaneous distortion and perspective correction

-Changes to framing or correction of converging verticals should be done 
simultaneously or after the correction of lens-induced distortions, never before, 
because distortion correction is only precise if the entire image is processed.!

- Filter > Distort > Lens Correction: allows to simultaneously correct barrel distortion 
from the lens and correct converging verticals. Crooked lines stand out more once 
perspective is corrected, so it makes sense to make both corrections at the same time.

- Remove Distortion slider corrects barrel distortion from the lens.

- Vertical Perspective slider in the Transform areas corrects converging verticals.

- the Straighten tool allows to draw a virtual line through the image, then the software 
reorients the image parallel to the line: Select the tape measure tool (it shares space 
with the eyedropper in Photoshop’s toolbox) and drag a line across part of your image 
that should be straight horizontal or vertical. Then choose Image > Rotate Canvas > 
Arbitrary. Photoshop auto-calculates the value required to straighten your image. 
Click OK and your image is all squared up.

2) Perspective correction using the Transform command

- for distortion-free images, or images after distortion corrections

- turn the Grid on or draw guide rulers (View menu)

- double click on the background layer thumbnail to make it editable (click OK in 
resulting dialog box)

- Edit > Transform > Perspective or Distort : the perspective of the image may now 
be distorted.

- If you move the upper corners outward, you need to move the lower corners inward 
otherwise the image will look wrong.

- send the correction layer to the background with Layer > Flatten Image.

3) Adjust the image frame



- best to only crop after the perspective has been corrected.

- to crop to a fixed aspect ratio: Select Crop tool and enter the desired ratio in the 
Width and Heigth (does not need to be the desired dimensions in cm, as long as the 
ratio is correct such as 3/2) and the crop marquee will be constrained to this ratio.

4) Selective Brightness adjustments:  Selective Darkening

- for example, to darken the sky

- Layer > Duplicate Layer to duplicate the background layer and make adjustments in 
it. Alternatively, create an adjustment layer (Layer >New adjustment Layer > Levels 
or Curves)

- 3 methods to select the sky:
1) If there is a clearly defined transition between the sky and the building, use the 
Magic Wand Tool (Holding the Shift key allows to expand the selection). 

2) If elements such as trees reach into the transition area, another method works 
better. Select > Color Range, click on an area of the sky in the preview box. The 
selected areas are then marked in white on the image, while the unselected area show 
up in black. Further areas can be selected with the Add to Sample eyedropper. The 
Fuzziness slider should remain on the lower setting. This method always adds areas 
outside the desired sky that may be corrected later.

- After clicking OK, the selected area show up in the main window.

- Select > Refine Edge allows to fine tune the edge. Set Radius and Contrast by trial 
and error. Set the Smooth and Feathers sliders to 0. Set Contract/Expand between 
+5% and +10% to avoid halos around the selected edges. 

- Click OK, check that the duplicated layer is active, Add Layer Mask. This layer 
mask gives a different opacity to the top layer, so that entire areas of a layer can be 
faded out without deleting pixels. The faded out areas can be reconstructed, for 
example by painting with a white brush within the layer mask.

- Make the Black and white selection layer mask visible by clicking on it while 
holding the Alt key.

3) Select all areas not belonging to the sky with the Polygonal Lasso tool.

- after selecting the relevant area with one of the 3 methods above, open Fill option 
from the Edit menu. Detailed correction can be done with the brush tool.

- select the layer thumbnail

- Select Levels from the Image > Adjustments menu.

- In the Input Levels histogram, slide only the grey triangle in the middle towards the 
right to darken only the midtones while preserving the highlights and shadows.

- Alternatively, Curves may be used instead of Levels.



- Because we are working with a layer mask, the changes only apply to the selected 
area.

5) Selective Brightness adjustments:  Selective Lightening

-Create another layer called 'lighten' (give it a name to avoid confusion when working 
with at least 2 layers).

- Different methods to make the dark areas of the image brighter:

1) Select > Color Range, select Shadows, apply strong softening to the layer mask.

2) Activate the layer by clicking on the thumbnail. Apply Levels or Curves as in the 
previous section. Create  a new layer mask. It is white, we want to fill it with black 
instead: use Fill in the Edit menu or Image > Adjustments > Invert. Select a large soft 
brush from the Brush tool, reduce the opacity of the brush to a small value (30%), set 
the foreground colour to white. Use the brush to paint over the selected dark areas of 
the layer mask that are too dark. Combine the layer into the background layer (Layer 
> Flatten Image).

6) Selective Brightness and Contrast Correction using Shadows/Highlights

- Image > Adjustments > Shadows/Highlights. The dialogue box shows sliders for 
Shadows and Highlights.

- Click Show more options.

- To brighten dark areas: use the Amount, Tonal Width and Radius sliders. Amount 
controls the intensity of the effect and depends on the image but should not be set too 
high. Tonal Width determines which hue of shadows is affected by the process: small 
values only affect extremely dark areas, while larger values also change brighter 
areas. Radius determines the size of the processed area surrounding the shadows:  a 
too small value causes bright bands or halos, but a too large value causes the effect to 
work only on large surface areas. The Midtone Contrast slider in the Adjustments area 
of the dialogue box  can restore the overall contrast if it has been diminished.

7) Selective Brightness and Contrast Correction using a contrast Mask

- To brighten dark areas.

- Duplicate the background layer (Layer > Duplicate Layer).

- Desaturate the new layer: Image > Adjustments > Desaturate 

- Change the layer to a negative image: Image > Adjustments > Invert
- Apply Gaussian blur: Filter > Blur, set Radius between 5 and 15 pixels depending 
on the size of the image.

- Set Blending Mode to Overlay and reduce Opacity to a value of 30 to 50%.



8) Selective Brightness and Contrast Correction using LightMachine plugin

- Shadow/Highlight mode, Auto mask window.

- Options for precise correction and avoiding halos.

9) Noise Reduction

- Filter > Noise > Reduce Noise if necessary.

- Noise reduction should be done cautiously because it causes loss of details. An 
image with a small amount of noise often looks better than an image where details 
have been suppressed by too aggressive noise reduction.

10) Colour correction: Selective Colour Correction/filtering.

- Image > Adjustments > Selective Color dialogue box allows precise colour 
correction.

- Example: 2 methods to cool an image. 

1) New > Layer from the Layer menu, select Color as the blending mode. Color the 
layer blue with Fill in the Edit menu, reduce the opacity a lot (10%). Use a layer mask 
to limit the blue tint effect to selected areas of the image only.

2) Alternative method: Layer > New Adjustment Layer > Photo Filter. Select a Blue 
Cooling filter with a density of 10%.

11) Colour correction: Saturation

- Layer > New Adjustment Layer > Hue/Saturation

12) Colour correction: Contrast 

- Image > Adjustments > Auto Contrast stretches the histogram until the darkest parts 
of the image are pure black and the lighter parts pure white.

- Image > Levels allows to manipulate the histogram manually.

13) Colour correction: Selective local Contrast 



- Duplicate the background layer.

- Filter > Sharpen > Unsharp Mask. Choose a large Radius that enhances the contrast 
along detailed edges, but also the contrast of larger areas of the image as a whole. 
Fine tune using the Amount slider.

- The drawback of this method is to create halos at the transition from contrast rich 
edges to larger areas. These halos can be corrected with a layer mask and a black 
paintbrush.

14) Sharpen the image.

2 methods:

1) Filter > Sharpen > Unsharp Mask as previously. Select a moderate Amount (90%), 
keep Radius between 0.3 and 1.0 depending on the original sharpness of the image, 
set Threshold between 0 and 3. Too high values for Amount and Radius create ugly 
artifacts. A too high Threshold value reduces the noise caused by sharpening in flat 
image areas, but also actually reduces the actual sharpening effect.

2) Smart Sharpen in later version of photoshop only.

15) Save the image file.

- TIFF or PSD for lossless saving with high color depth. If the image won't be 
processed further, reduce colour depth to 8 bits (Image > Mode > 8 Bits/Channel).
- JPEG with quality of 10 or 11.
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